Install ruby 1.8.7 with rvm on Mac OS X 10.8

Moin Moin,

if you have trouble installing ruby 1.8.7 via rvm on Mac OS X 10.8 (Mountain Lion), please check out these advices from Matteo Alessani:

http://stackoverflow.com/questions/11664835/mountain-lion-rvm-install-1-8-7-x11-error

Short summary:

  1. install X11 via http://xquartz.macosforge.org/landing/
  2. export CPPFLAGS=-I/opt/X11/include
  3. CC=/usr/local/bin/gcc-4.2 rvm reinstall 1.8.7

All credits for this to Matteo Alessani

Cheers

Andy

Published: October 09 2012